Curso de Flash 4.0


2. Inicialização do Flash 4

O processo de inicialização do Flash 4 é feito de maneira semelhante a todos os programas instalados no computador. Esta apostila partirá do princípio que o sistema operacional presente na máquina é o Windows 98.

2.1. Através do menu Iniciar

1. Clique no botão Iniciar e em seguida escolha o menu Programas;

2. Selecione a opção Macromedia Flash 4;

3. Em seguida escolha a opção Flash 4;
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4. Aguarde a inicialização do programa.
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A tela anterior mostra o carregamento do programa.

2.2. Ícone de Atalho

No item anterior foi mostrado como inicializar o programa Flash 4 através do menu Iniciar do Windows 98. Este sistema operacional oferece a possibilidade para os usuários executarem seus programas a partir de um ícone de atalho que pode estar presente na Área de trabalho do Windows.

Para executar o programa Flash 4 a partir de um atalho desses, basta o usuário posicionar o mouse sobre o respectivo ícone e clicar duas vezes o botão esquerdo. Assim o programa é carregado da mesma maneira que o método anterior.

Observe uma parte da Área de Trabalho exibindo o ícone de atalho do programa Macromedia Flash 4.
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Dica: Para criar um atalho, na Área de Trabalho consulte o respectivo item na ajuda do Microsoft Windows.

3. Tela de Abertura

Antes de iniciar a criação e manipulação de movies no Flash 4, será apresentada toda a interface do ambiente de desenvolvimento para que o usuário possa acostumar-se às posições de determinados elementos e também a nomenclatura dada a cada um deles.
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A tela de abertura do Flash 4 possui todas as características das telas de programas criados para funcionarem em plataformas gráficas. Os elementos não relacionados nesta apostilas são comuns a estas telas, portanto foram suprimidos.

3.1. Barra de Menus

Geralmente, esta barra encontra-se na parte superior da tela do programa, abaixo da barra de título. Esta barra tem como característica básica a apresentação das várias ferramentas e operações presentes no programa.
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Cada programa apresenta o seu conjunto de opções de menu. No Flash, estas opções são as seguintes:

· File – Aqui encontram-se as opções de abertura de novos arquivos, fechamento, salvamento, impressão e encerramento do programa.

· Edit –  Neste menu encontram-se as opções Recortar, Copiar , Colar e opções de seleção e operações com Frames.

· View – Além da opção Go to, existem as opções de visualização ou não dos elementos que compõem a tela do Flash .

· Insert – As opções de inserção de Frames, Keyframes, Layers e Scenes estão presentes neste menu.

· Modify – Neste menu encontram-se todas as opções de modificação de Frames, Scenes, Layers, Fontes, Parágrafos e outros elementos.

· Control – As operações de execução dos filmes criados no Flash são apresentados neste menu.

· Libraries – Local onde encontram-se as bibliotecas de figuras, animações, botões e sons do programa.

· Windows – As opções de trabalho com janelas estão presentes neste menu.

· Help – Aqui encontram-se as várias formas de obter-se ajuda no Flash 4, inclusive os exemplos de técnicas interativas.

3.2. Barra de Ferramentas Padrão

Localizada abaixo da barra de menus, a Barra de Ferramentas Padrão do Flash apresentada as principais operações e ferramentas existentes no programa. Os botões apresentados nesta barra permitem com que o usuário execute tarefas de maneira mais rápida e fácil, porém deve-se atentar para o fato de que estes botões executam tarefas padrões, por exemplo – para imprimir uma seqüência completa de frames, basta o usuário clicar no botão correspondente, mas se quiser imprimir apenas alguns, deve-se obrigatoriamente selecionar a opção Print no menu File.

A figura abaixo mostra a Barra de Ferramentas Padrão:


[image: image6.png]D& E| SR &[EB@| olc| A =5~ 5@k = =]





3.3. Barra de Desenhos

Esta barra encontra-se localizada no lado esquerdo da tela do Flash. Com as ferramentas existentes nesta barra, o usuário pode criar e manipular vários tipos de desenhos vetoriais, incluindo cores, borrachas, zoom e captura de áreas.

Abaixo desta barra existe uma caixa de complementos que é atualizada conforme a ferramenta escolhida na Barra de Desenhos. Observe alguns exemplos:
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Observe que, dependendo da ferramenta selecionada, os elementos que encontram-se na caixa de complemento também acompanham a mudança.

A seguir são apresentadas as descrições de cada ferramenta presente na Barra de Desenho do Flash 4:
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 Arrow – esta ferramenta é usada para selecionar, arrastar e transformar elementos gráficos e de texto.
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 Lasso – esta ferramenta permite que seja selecionada uma área irregular em uma imagem inserida na área de desenho.
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 Line – esta ferramenta permite o tracejamento de linhas perfeitamente retas, sendo estas na horizontal vertical ou diagonal.
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 Text – esta ferramenta é usada para inserção de textos dentro da área de trabalho dos filmes criados em Flash. 
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 Oval – esta ferramentas produz formas ovais ou circulares. 
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 Rectangle – esta ferramenta tem como base a criação de formas retangulares e quadradas, onde estas podem assumir os cantos arredondados se assim o usuário desejar.
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 Pencil - esta ferramenta é usada para desenhar linhas retas, angulares ou a 
mão-livre.
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 Brush - esta ferramenta permite o desenho livre e através de vários elementos já existentes pode-se definir opções de comportamento das linhas.
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 Ink Bottle - esta ferramenta é usada para substituir cores, espessuras de linhas e os estilos delas.
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 Paint Bucket - esta ferramenta é utilizada para preencher áreas fechadas ou nãocom determinadas cores escolhidas pelo usuário.
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 Dropper - esta ferramenta captura informações de cores e estilos para serem aplicados em outras partes do desenho.
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 Eraser - esta ferramenta permite apagar linhas e cores presentes na área de desenho assumindo vários formatos.
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 Hand – esta ferramenta permite que a área de desenho seja arrastada para que o usuário possa visualizar o que se encontra além dela.
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 Magnifier - esta ferramenta amplia e reduz o tamanho de uma determinada parte do desenho definida pelo usuário.

Algumas das ferramentas apresentadas possuem o recurso de aplicação de cores e assim é mostrada uma caixa de cores para que o usuário possa escolher a que mais atende à sua necessidade no momento.

Abaixo é exibida a caixa de cores mencionada:
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Dica: As cores apresentadas na caixa de cores podem variar conforme o usuário cria suas próprias cores personalizadas.

Ao clicar no botão de personalização surgirá na tela a caixa de diálogo de personalização de cores com duas guias; Solid e Gradient:
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Caixa de diálogo Color e guia Solid.


[image: image29.png]soid . Gradin |

] [on] o] " ey _Creee |





Caixa de diálogo Color e guia Gradient.
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1. Clique em New ( Novo ) para criar novo gradiente ( opcional ) 

2. Formas de Gradiente : Linear ou Radial 

3. Paletas de cores 

4. Cores em RGB ; caso ( x ) Hex - Cores em Hexagonal 

5. Seletor de Cores 

6. Intensidade da Cor 

7. Outras formas da Cor :
Add Colors - adicionar cor
Replace Colors - recolocar cor
Load Default Colors - carregar cores default
Save Colors - salvar cor
Save as Default - salvar cor como default
Clear Colors - deletar cor
Web 216 - usar 216 cores para Web
Sort by Color - tipo de cor 

LAYER – CAMADAS

Olho - visualizar ou esconder layer
Cadeado - trancar ou destrancar layer 

Quadrado - exibir ou não somente os contornos do layer 
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 Add Layer ( folha branca ) - adicionar layer ( camada )
Add Layer Guide ( folha lilás ) - adicionar layer guide , usado no efeito Add Motion Guide 



Delete Layer - deletar layer ( camada )
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3.4. Linha do Tempo

A linha do tempo (Timeline) é composta de uma escala horizontal onde os frames são dispostos e à medida em que o indicador a percorre, a animação é executada. Praticamente todo o trabalho de elaboração do filme será feito a partir das ferramentas da linha do tempo.

Na linha do tempo encontram-se quatro botões que controlam a apresentação dos quadros da animação. Esses botões ligam e desligam a apresentação de quadros anteriores e posteriores ao quadro da animação ativo.
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A partir da linha do tempo encontra-se os vários recursos que podem ser aplicados ao quadros que compõem o filme:
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 Nome da(s) cena(s) que o filme possui.
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 Edit Scene (Editar a cena) e Edit Symbol (Editar o símbolo).
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 Exibir/Ocultar, Travar/Destravar e Exibir camadas como Outlines.
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 Nome da camada.
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 Adicionar camada e guia para camada.
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 Excluir camada.
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 Opções de configuração Onion skins e quadros.

3.5. Área de Edição

Abaixo da linha do tempo encontra-se a Área de Edição cujo local é utilizado para a criação dos desenhos que comporão os quadros da animação. Esta área possui uma parte branca e outra cinza, sendo que a primeira é a área disponível para colocação dos elementos da apresentação e a segunda apenas é utilizada para auxiliar o usuário na disposição de tais elementos quando estes forem em grande quantidade quando estiverem sendo manipulados.
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Dica: se por acaso quiser fazer com que a área cinza fique oculta basta escolher a opção Work Area no menu View.

4. Utilização das Ferramentas de Desenho

Para efetivamente saber como e quando utilizar as ferramentas de desenho do Flash é necessário praticar e neste capítulo será abordada a utilização da maioria das ferramentas de uma maneira rápida, consistente e adequada.

Algumas das ferramentas que serão apresentadas a seguir poderão ser utilizadas em conjunto com outras para produzirem um objeto mais complexos. Essas informações não devem ser simplesmente copiadas pois o número de recursos podem multiplicar-se com a eventual combinação das várias ferramentas existentes.

4.1. Ferramentas Pencil e Line

A ferramenta Pencil possui na caixa de complementos uma série de variedades que farão mudar o seu efeito inicial. São eles:
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· Straighten – se houver linhas curvas estas são convertidas em linhas retas.

· Smooth – desenha linhas com um arredondamento suave.

· Ink – traça linhas livremente.

Nesta caixa de complementos ainda encontram-se as opções de cor, espessura e estilo para as linhas que serão desenhadas.

Para executar algumas operações com a ferramenta Pencil, execute os passos abaixo:

1- Selecione a ferramenta Pencil e o complemento Smooth;

2- Selecione uma cor azul qualquer e a espessura 4.0;

3- Aponte para a área de edição e faça o desenho abaixo;
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4- Agora selecione uma cor vermelha qualquer e a espessura 2.0;

5- Selecione o complemento Straighten;

6- Aponte para a área de edição e arraste o mouse de forma ondulada. Verifique que a linha passa a ter linhas retas no lugar das curvas;

7- Clique na ferramenta Arrow, aponte para um canto da área de desenho, arraste na diagonal até que os dois desenhos feitos fiquem dentro da seleção (quadrado riscado) e solte o mouse para selecionar os dois;

8- Pressione a tecla DEL para eliminá-los.

A ferramenta Line trabalha de forma semelhante à ferramenta Pencil, com a diferença de que ela cria somente linhas retas horizontais, verticais e diagonais onde deve-se definir apenas o ponto inicial e o final através do arraste do mouse. 

4.2. Ferramentas Oval e Rectangle

Agora serão utilizadas duas ferramentas que permitem a criação de quadrados, retângulos, círculos ou elipses onde estes terão o preenchimento como um novo componente de formatação.

[image: image70.png]A alol B G 2oks | oos



[image: image71.png]( X )




[image: image42.png]HNl =

St =

L]
]






[image: image43.png]





[image: image44.png]S HE




Observe que a ferramenta Rectangle possui uma opção de complemento a mais que é a definição de cantos arredondados para o desenho criado com ela.

Nos dois complementos encontram-se as opções de cor de linha, espessura, estilo e a cor de preenchimento.

Siga os passo abaixo:

1- Selecione a ferramenta Oval, a cor vermelho para a linha e a espessura 2.0;

2- Selecione a cor amarela para o preenchimento;

3- Aponte o mouse para a área de edição e desenhe um círculo;

4- Agora selecione a ferramenta Rectangle e defina outras opções de complemento;

5- Desenhe um quadrado ou um retângulo na área de edição ao lado do círculo;

6- Após a criação dos dois objetos, a tela fica assim;
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7- Selecione a ferramenta Arrow, clique no meio do quadrado para selecioná-lo;

8- Pressione a tecla SHIFT e clique no círculo para incluí-lo na seleção;

9- Com os dois objetos selecionados, pressione a tecla DEL para eliminá-los e observe que apenas os preenchimentos foram apagado;

10- Selecione os dois contornos através da opção Select all no menu Edit e apague-os com o DEL novamente.

Faça outros desenhos utilizando os outros complementos como os encontrados abaixo:
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Dica: Para criar um quadrado ou círculo perfeito, enquanto estiver arrastando-os, pressione a tecla SHIFT. Uma outra opção parecida é a ativação prévia da opção 
Snap 
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 na barra de ferramentas e assim observa-se, durante o processo de arraste, um círculo pequeno acompanhando o mouse mostrando que o desenho sairá com a mesma altura e largura.

4.3. Ferramentas Brush e Paint Bucket

A ferramenta Brush assemelha-se basta à ferramenta Pencil pois também é possível a criação de desenhos à mão-livre. A diferença básica entre as duas é que a ferramenta Brush possui uma caixa de complementos que permite o usuário escolher o formato e a aplicação a ser usada.
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No conjunto de figuras mostradas, observa-se que ao clicar na ferramenta Paint Bucket, esta mostra opções de configuração de cor de preenchimento e escalas de aberturas mínimas para elementos fechados (ou semi-fechados). São elas:

· Don’t Close Gaps – aplicação à figuras totalmente fechada.

· Close Small Gaps – aplicação à figuras com uma pequena abertura.

· Close Medium Gaps – aplicação à figuras com uma média abertura.

· Close Large Gaps - aplicação à figuras com uma abertura considerável.

A ferramenta Brush apresenta uma outra caixa de complementos que permite a seleção da espessura e modelo do pincel, bem como a forma de sua aplicação. São elas:

· Paint Normal – pinta sobre qualquer parte do desenho existente.

· Paint Fills – pinta apenas sobre as cores de preenchimento.

· Paint Behind – pinta somente sobre as áreas vazia da tela.

· Paint Selection – pinta somente nas áreas previamente selecionadas.

· Paint Inside – pinta somente na área em que a pintura foi iniciada.

Execute os passos abaixo:

1- Selecione a ferramenta Brush;

2- Escolha a cor verde para cor da linha, a terceira espessura e o formato quadrado;

3- Desenhe uma figura qualquer na área de edição contanto que seja fechada;

Observe o exemplo abaixo:
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4- Selecione a ferramenta Paint Bucket, escolha a cor amarelo e dê um clique com a lata de tinta (a forma que o mouse assumiu.) dentro da área da figura;

Observe que a figura ficou com o preenchimento amarelo.

5- Selecione novamente a ferramenta Brush, escolha a cor azul e o complemento denominado Paint Behind;

6- Faça um risco com o Brush de um lado a outro da figura;

Observe na figura a seguir que o risco azul foi aplicado apenas na parte externa da figura pois o complemento selecionado assim o define.
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Dica: O botão Lock Fill 
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 faz com que a aplicação da cor de preenchimento dada a uma parte da figura pode ser aplicado proporcionalmente a outra sem a necessidade de criar novamente. O botão Transform Fill 
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 permite modificar a direção e a amplitude de preenchimentos em degradê.

4.4. Ferramenta Ink Bottle e Eraser

A ferramenta Ink Bottle serve para modificar características que foram aplicadas em determinados desenhos e assim apresentá-los de maneira diferente, como por exemplo, desenhar uma linha com espessura grossa vermelha e mudar para fina azul depois que ela já tenha sido desenha na área de edição.

Execute os passos abaixo:

1- Desenhe um retângulo com linhas azuis e espessura 2.0;

2- Agora escolha a ferramenta Ink Bottle, a espessura 8.0 e em seguida a cor azul;

3- Aponte a ponta do vaso (a forma que o mouse assumiu.) exatamente em cima de qualquer parte da linha do retângulo.

Observe que as linhas que formam a figura mudaram para o novo formato.

A ferramenta Eraser permite a eliminação de partes da figura dependendo do complemento selecionado que se parece bastante com os da ferramenta Brush com a diferença de que este não muda de cor e sim elimina determina cor.
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· Erase Normal – apaga tudo por onde o mouse passar.

· Erase Fill – apaga apenas o preenchimento de figuras fechadas.

· Erase Lines – apaga apenas as linhas de uma figura.

· Erase Selected Fills – apaga apenas as áreas selecionadas.

· Erase Inside – apaga apenas a cor a partir da área inicialmente escolhida.

Execute os passos abaixo:

1- Desenhe um retângulo com um preenchimento amarelo, linha vermelha e espessura de linha 4.0;

2- Selecione a ferramenta Eraser e escolha o complemento Erase Normal e faça um risco com a borracha na horizontal atravessando toda a área do retângulo;

3- Faça a mesma operação com os complementos Erase Fill e Erase Line.

Observe na figura abaixo que o retângulo sofre diferentes formas de eliminação de suas partes conforme o complemento escolhido:
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Dica: O botão Faucet 
[image: image61.png]


 permite eliminar qualquer parte da figura incondicionalmente, bastando para isso, selecioná-la e clicar em cima do elemento desejado.

AULAS PRATICAS DE FLASH

BOTÃO ANIMADO

Estágios do Botão 
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O botão tem quatro estágios :               


Up - como o botão aparece sem passar o mouse
Over - como o botão aparece quando o mouse passa por cima do botão
Down - como o botão aparece quando você clica no botão
Hit - define a área " clicável " do botão, ou seja, a área em que ele é acionado     

Observação : Quando se transforma um objeto em botão , ele tem uma opção : Tracking Options que possui duas opções : Track as Button que evita que outros botões recebam a Ação " On Mouse Events " enquanto o mouse está no estágio down ; Track as Menu Item que permite que outros botões recebam a Ação " On Mouse Events - Release " . 
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Exercício 13 - Botão 1 
1. Window > Library > Options > New Symbol 
2. Name : botão1 ; behavior : button 

3.  Desenhe uma bola em azul 

4. Clique duas vezes sobre a bola para selecionar o polígono e o contorno 

5.  Crtl + D ou Edit > Duplicate para duplicar a bola 

6.  Com as setinhas do teclado arraste a cópia da bola para fora totalmente 

7.  Modify > Transform > Scale and Rotate 

8.  Scale : 90 ; Rotate : 0 

9. Com as setinhas do teclado arraste a cópia da bola para o meio da primeira bola 

10. Selecione a duas bolas > Crtl + G ou Modify > Group para agrupar as duas bolas, tornando-as um só polígono 

11. Digite em branco e Arial Black no botão a palavra ENTRE 

12. Selecione o botão > Crtl K para centralizar no sinal ( + ) o símbolo botão1 

13. Vertical > Align > selecione o terceiro botão ;
Horizontal > Align > selecione o terceiro botão ;
Match Size > selecione o primeiro botão ( x ) ;
( x ) marque Align to Page 

14. Selecione a linha do tempo os estágios Over, Down e Hit 

15. F6 ou Insert > Keyframe 

16. Selecione na linha do tempo o estágio Over 

17. Modify > Transform > Scale and Rotate 

18. Scale : 120 ; Rotate : 0 

19.  Selecione somente a palavra Entre 

20. Selecione a ferramenta de Texto e troque a cor para amarelo 

21. Selecione na linha do tempo o estágio Down 

22. Modify > Transform > Scale and Rotate 

23. Scale : 80 ; Rotate : 0 

24. Selecione somente a palavra Entre 

25. Selecione a ferramenta de Texto e troque a cor para verde 

26. Deixe o estágio Hit como está , ou seja , igual ao estágio Up 
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Clique em Scene 1 
para voltar a Cena 1 
28. Arraste da Library ( Biblioteca ) o desenho do botão 1 para área de trabalho 

29. Salve o arquivo como exer13.fla 

30. Crtl + Enter e teste sua animação 

31.  Passe o mouse sobre o botão 

32. Crtl + F4 para voltar a área de trabalho
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Exercício 14 - Botão 2 PRIVATE "TYPE=PICT;ALT=Download do Exer" 

1. Window > Library > Options > New Symbol 

2. [image: image82.png]


 Name : botão2 ; behavior : Button

3.  Selecione a ferramenta Rectangle 

4.  Clique na ferramenta auxiliar do retângulo > Round Rectangle Radius e no item Corner Radius digite 10 

5.  Desenhe uma retângulo em vermelho 

6.  Digite em branco e Arial Black no botão a palavra CADASTRO 

7.  Selecione o botão > Crtl K para centralizar no sinal ( + ) o símbolo botão2 

8. Vertical > Align > selecione o terceiro botão ;
Horizontal > Align > selecione o terceiro botão ;
Match Size > selecione o primeiro botão ( x ) ;
( x ) marque Align to Page 

9.   Selecione a linha do tempo os estágios Over, Down e Hit 

10.  F6 ou Insert > Keyframe 

11.   Selecione na linha do tempo o estágio Over 

12.   Selecione somente a palavra CADASTRO 

13.  Selecione a ferramenta de Texto e troque a cor para azul 

14.  Selecione na linha do tempo o estágio Down 

15.  Selecione somente a palavra CADASTRO 

16.  Selecione a ferramenta de Texto e troque a cor para amarelo 

17.  Deixe o estágio Hit como está , ou seja , igual ao estágio Up 
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 Clique em Scene 1 
para voltar a Cena 1 

19.  Arraste da Library ( Biblioteca ) o desenho do botão 2 para área de trabalho 

20.  Salve o arquivo como exer14.fla 

21.  Crtl + Enter e teste sua animação 

22.  Passe o mouse sobre o botão 23. Crtl + F4 para voltar a área de trabalho
CONCEITOS FUNDAMENTAIS

TIMELINE - LINHA DO TEMPO
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Bolinha preta - Keyframe , isto é , há desenho na linha do tempo = 1 Bolinha branca - Blank Keyframe , isto é , não há desenho na linha do tempo = 5 Linha preta - Frame , isto é , repete a penúltima linha do tempo na linha = 10 que pode ser um keyframe ou blank keyframe
ALINHAMENTO DE DESENHO
Para alinhar > seleciona o desenho > Crtl K ou Modify > Align
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Alinhamento pode ser na Vertical , Horizontal e Tamanho da Área de Trabalho ( Match Size )

X - não alinha desenho
Space Evently - alinha o espaço entre desenhos
Cruz que está no Match Size - expande o objeto para o tamanho da tela
Align to Page - alinha o desenho no meio da Área de Trabalho
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TAMANHO DA ÁREA DE TRABALHO
Para modificar o tamanho da área de trabalho > clique em 12.0 fps 
Frame Rate - define quantos frames por segundo , por default 12.0
Dimensions - define as dimensões da área de trabalho
Match - Printer - define tamanho exato da impressão
Match - Contents - reajusta o tamanho da tela para somente o espaço que foi ocupado a animação
Grid Spacing - define tamanho da grade
Grid - exibir ou não a grade para auxiliar a desenhar a animação
Colors - Grid - define a cor da grade
Colors - Background - define a cor do fundo da animação
TÉCNICA PARA MODIFICAR FORMA DO DESENHO
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PRIVATE
1. Desenhe uma bola
2. Clique na ferramenta seta ( Arrow ) e arraste uma das bordas para fora para redefinir forma do desenho

F A Q - PERGUNTAS MAIS FREQUENTES

1 - Como evitar que uma imagem em gif transparente quando importada para o Flash não apareça manchas em sua volta ?
Tente salvar a imagem com extensão PNG e uma vez importada, diminua um pouco o Alpha ; outra maneira é : selecione a imagem > Modify > Trace Bitmap e a imagem se torna um Bitmap e com a ferramenta borracha apague as manchas em sua volta

2 - O Flash reconhece gifs animadas ou com extensão avi ?
Sim . Inclusive uma vez importada, ele cria automaticamente todos os frames do arquivo
3 - Qual é a melhor extensão e resolução para importar imagens ou fotos para o Flash ? A melhor extensão é PNG com resolução 72 dpi

4 - Qual é o melhor formato de som para importar para o Flash ?
O melhor formato de som é : Wav - 22 Khz - 16 bits Mono - PCM ou ADPCM
5 - Qual ação que deve ser inserida em um botão para que feche a página quando clicado usando javascript ?
Clique sobre o botão > Properties > Action > Get URL e digite do lado direito :
javascript:window.close();

6 - Como transformar textos em cores gradientes ?
Existem duas maneiras : a primeira : selecione o texto > Modify > Break Apart transformando as letras em imagens > insira cores em gradiente ; a segunda : usando o efeito Mask ( máscara ) ; veja capítulo sobre Máscara na 2ª parte do Curso
7 - Como inserir uma gif de um cenário para a minha animação ?
O cenário deve ser o último layer da animação e não tem nada haver com o background . O background cria uma cor sólida que se modificada, muda o fundo todas as cenas automaticamente ; enquanto que usando cenário, você pode inserir em cada cena cenários diferentes
8 - Como inserir um Movie Clip no estágio Over do botão ?
Crie um botão com os quatros estágios normalmente ; Windows > Library > Options > New Symbol > e crie um novo símbolo como movie clip ; Volte a edição do botão e arraste o movie clip para cima do estágio Over.
9 - Como transformar a animação em Flash em um arquivo executável ?
Junto com o Flash vem um programa chamado Standalone Player que transforma sua animação em um arquivo executável ; maiores detalhes veja o capítulo sobre o Standalone Player na 2ª parte do Curso.
10 - Quando executo uma animação em Flash que transformada em executável no Standalone Player , aparece uma barra indesejável. Como retirar esta barra ? 
Insira uma ação no primeiro frame do primeiro layer > Properties > Actions
FSCommand > Command = FullScreen e Argument = True

11 - Qual é a melhor dimensão para criar uma animação em rodar na tela toda do monitor ?
A melhor dimensão é sempre a proporção 4 x 3 que serve para as configurações dos monitores 600x480 , 800x600 e 1024x768 , pois o Flash é vetorial ; para que uma animação apareça totalmente na tela, você deve inserir no primeiro frame do primeiro layer uma ação > Actions > FSCommand > Command = fullscreen > Argument = true
12 - Importei uma imagem para minha animação e quando fui testar apareceu umas manchas . Existe alguma maneira de melhorar a qualidade da imagem importada no Flash ? 
Sim. Quando você dá Crtl + Enter a animação se transforma em swf com valor de compressão 50 jpeg ( default ) ; não use Crtl + Enter e sim , File > Export Movie e no item jpeg modifique o fator de compressão entre 0 e 100 ; quanto menor a compressão melhor a qualidade da imagem
13 - Criei uma animação com várias Cenas e quando mando rodar , ela roda todas as Cenas sem parar. Como faço para parar em cada Cena ?
Insira no último frame do primeiro layer a ação Stop de cada Cena e coloque em cada Cena um botão para ir para próxima Cena ( veja este exemplo na 2ª parte do Curso )
14 - Para que serve o Template ?
Serve para utilizar o Generator no Flash na busca de dados , arquivos , entre outros . O Generator é um outro programa da Macromedia que cria Flash Dinâmico; puxe a versão demo :
http://www.macromedia.com/generator
15 - O Flash 4.0 importa som em MP3 ?
Não. O Flash 4.0 não importa som em MP3 , ele somente exporta a compressão de um som wav em MP3 ( maiores detalhes veja capítulo sobre Som na 2ª parte do Curso )
EFEITO ADD MOTION GUIDE

O efeito Add Motion Guide é a maneira que você cria os caminhos por onde passará sua animação ,mas para que ocorra o Add Motion Guide, você deve criar primeiramente o Motion Tweening 
( conforme mencionamos no capítulo anterior )
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Add Motion Guide 

1. Desenhe uma bola 
2.  Clique na ferramenta Arrow ( Seta ) ;
Clique duas vezes sobre a bola para selecionar toda a bola ( contorno e preenchimento ) 

3.  Aperte a tecla F8 para transformar a bola em símbolo 

4. Abrirá uma Caixa de Diálogo : Name : bola ; behavior : graphic ;
Observe que quando se cria um símbolo > aparece um sinal ( + ) dentro do objeto 

5. Selecione a linha do tempo = 50 

6. Insira um keyframe na linha do tempo = 50 ou seja aperte a tecla F6 ou
botão direito do mouse > Insert > Keyframe 
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Quando se insere um keyframe, estamos repetindo o objeto do frame anterior ;
mas para que haja animação devemos mudar a posição do objeto referente a linha do tempo = 50 , no caso a bola ; para outra posição 

8. Selecione a linha do tempo = 1 ;
botão direito do mouse > Create Motion Tweening , para inserir o efeito tweening motion ; observe que na linha do tempo entre a linha 1 até 49 foi exibido uma linha em cor preta, significando que nesta etapa da animação há um Tweening Motion
9. Clique na folha lilás ( Add Guide ) 

10. Clique no ícone Edit Multiple Frames ( Editar múltiplos frames )
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11. Na linha do tempo ao clicar o ícone Edit Multiple Frames aparecerá um marcador em cinza que deve ser arrastado para cada eixo da animação, isto é , um para linha do tempo = 1 e o outro para linha = 50 

12. Clique na ferramenta Pencil ( Lápis ) e escolha o modo Smooth ( traçado suave ) 

13. As duas bolas devem estar selecionada 

14. Selecione a ferramenta imã 
15. Desenhe o caminho por onde passará a bola , iniciando dentro do sinal ( + ) de uma das bolas e terminando no eixo ( + ) da outra bola 

16. Sempre ao terminar o Add Motion Guide > desativar o ícone Edit Multiple Frames 

17. Salve sua animação, neste caso, exer06.fla 

18. Há duas maneiras de exportar a animação ou seja para rodar a animação :
* Crtl + Enter ou
* File > Export Movie 

19. Para voltar à área de trabalho > Crtl + F4
Dança das Letras

1. Digite em Arial Black ; tamanho 48 , azul ,a palavra : A M O R ( com espaço ) 

2. Selecione a ferramenta Arrow ( Seta ) 

3. Crtl + K para centralizar no meio na página 

4. Mantenha o texto selecionado > Ctrl + B ou Modify > Break Apart, para transformar o texto em imagem 

5. Selecione somente a letra A > F8 > symbol : A ; behavior : graphic 

6. Selecione somente a letra M e usando a ferramenta balde, pois a palavra deixou de ser texto e é uma imagem e pinte de vermelho 

7. Mantenha o M selecionado > F8 > symbol : M ; behavior : graphic 

8. Selecione somente a letra O e usando a ferramenta balde, pois a palavra deixou de ser texto e é uma imagem e pinte de verde 

9. Mantenha o O selecionado > F8 > symbol : O ; behavior : graphic 

10. Selecione somente a letra R e usando a ferramenta balde, pois a palavra deixou de ser texto e é uma imagem e pinte de laranja 

11. Mantenha o R selecionado > F8 > symbol : R ; behavior : graphic 
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Selecione a linha do tempo = 1 > botão direito do mouse > Copy Frame ( Copiar Frame )
13. Clique no ícone 
Add Layer ( Adicionar Layer ) três vezes , pois a palavra tem quatro letras e como já tínhamos um layer, precisamos de mais três layers 
14. Selecione a linha do tempo = 1 de cada layer récem-criado separadamente > botão Direito do mouse > Paste Frame ( Colar Frame ) 
15. Clique duas vezes sobre o primeiro layer e renomeie para A 
16. Clique duas vezes sobre o segundo layer e renomeie para M 
17. Clique duas vezes sobre o terceiro layer e renomeie para O 
18. Clique duas vezes sobre o quarto layer e renomeie para R 
19. [image: image92.png]


Selecione a linha do tempo = 50 dos quatro layers > F6 para inserir keyframe
20. Clique no ícone olho para esconder o layer M , O , R 
21.  Selecione a linha do tempo = 1 do layer A 

22. Selecione na área de trabalho as letras M , O , R > delete 

23. Selecione a linha do tempo = 50 do layer A 

24. Selecione na área de trabalho as letras M , O , R > delete 

25. Mantendo a linha do tempo 1 coloque a letra A na parte superior à direita da tela 
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Clique na linha do tempo = 1 > botão direito do mouse > Create Tweening 

27. Clique na folha lilás ( Add Guide ) 
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Clique no ícone Edit Multiple Frames ( Editar múltiplos frames )

29. Na linha do tempo ao clicar o ícone Edit Multiple Frames aparecerá um marcador em cinza que deve ser arrastado para cada eixo da animação, isto é , um para linha do tempo = 1 e o outro para linha = 50 
30. Selecione a letra A nas duas posições 

31. Selecione a ferramenta imã 
32. Selecione a ferramenta Pencil ( Lápis ) e desenhe o caminho por onde passará a bola , iniciando dentro do sinal ( + ) de um A e terminando no eixo ( + ) do outro A 
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Windows > Controller para abrir o Controlador e aperte play para testar a movimentação da letra A , caso não tenha feito a movimentação desenhada por você > Crtl + Z e volte a desenhar o caminho novamente 

34. Sempre ao terminar o Add Motion Guide > desativar o ícone Edit Multiple Frames 

35.  Esconda também o Layer : Guide A 

36. Repita o mesmo procedimento com as outras letras, encondendo sempre os layers das letras que não esteja trabalhando ; siga as instruções dos itens 20 ao 33 , selecionando em cada letra na linha do tempo = 1 com posições diferentes. 

37. Terminando todas as letras clique no olho para visualizar todos os layers 

38. Salve sua animação, neste caso , exer07.fla 

39. Crtl + Enter 

40. Para voltar à área de trabalho > Crtl + F4
MENU DO FLASH

File - Arquivo 
New 


criar novo arquivo 

Open 


abrir arquivo 

Open as Library 
abrir arquivo com biblioteca 

Close 


fechar arquivo 

Save 


salvar arquivo 

Save as 

salvar arquivo como 

Revert 

voltar para a última vez que salvou arquivo 

Import 

importar imagens ou sons 

Export Movie 
exportar animação , ou seja , arquivo.swf 

Export Image 
exportar imagem 

Publish Settings 
parâmetros para publicar 

Publish Preferences preferências para publicar 


Publish 

publicar 

Page Setup 

parâmetros da página 

Print Preview 
previsão da impressão 


Print 


imprimir 

Send 


enviar 

Preferences 

preferências 

Assistant

assistente
Edit - Editar
 Undo 


voltar à ultima modificação 

Redo 


avançar para próxima modificação 

Cut 


recortar 



Copy 


copiar 

Paste 


colar 

Paste in Place 
colar no lugar 

Paste Special 
colar especial 

Clear 


deletar 

Duplicate 

duplicar 

Select All 

selecionar tudo 

Deselect All 

deselecionar tudo 

Copy Frames 
copiar frames 

Paste Frames 
colar frames 

Edit Symbol 

editar símbolo 

Edit Selected 
editar seleção 

Edit All 

editar tudo 


Insert Object
 inserir objeto 

Links Objeto 
Vincular Objetos

View - Visualizar
PRIVATE
Go to
ir para

100%
visualizar o tamanho original da animação

Show Frames
exibir frames

Show All
exibir tudo

Outlines
exibir contornos

Fast


Antialias
não exibir serrilhamento no objeto

Antialias Text
não exibir serrilhamento no texto

Timeline
exibir linha do tempo

Work Area
exibir área de trabalho

Rulers
exibir réguas

Grid
exibir grade

Snap
exibir imã

Show Shape Hints
exibir shape hints, quando se usa o efeito Shape

Insert - Inserir
Convert to Symbol 
transformar para símbolo 

New Symbol 

criar novo símbolo 

Layer



inserir camada 

Motion Guide 

inserir efeito Motion Guide 

Frame 


inserir frame ( quadro ) 

Delete Frame 

deletar ( quadro ) 

Keyframe 
inserir novamente o mesmo objeto do último frame ( quadro ) 

Blank Keyframe

inserir um frame ( quadro ) vazio 

Clear Keyframe 

deletar frame ( quadro ) 

Create Motion Tweening criar efeito Motion Tweening Scene inserir cena nova 

Remove Scene 

remover cena
Modify - Modificar
Instance


 modificar instância 

Frame 


modificar frame ( quadro ) 

Layer 



modificar layer ( camada ) 

Scene 


modificar cena 

Movie 


modificar animação 

Font 



modificar fonte 

Paragraph 


modificar parágrafo 

Style 
modificar estilo da fonte : plano, negrito , itálico e alinhamento 

Kerning


modificar espaço entre as linhas do texto 

Text Field 


modificar campo de preenchimento 
Scale 



modificar escala 

Rotate 


modificar rotação 

Scale and Rotate 

modificar escala e rotação 

Rotate Left 


rotacionar à esquerda 

Rotate Right 

rotacionar à direita 

Flip Vertical 


rotacionar 180º na vertical 

Transform
Flip Horizontal 

rotacionar 180º na horizontal 

Remove Transform 
remover modificações 

Edit Center 


editar centro 

Remove Colors 

remover cores 

Add Shape Hints 

adicionar Shape Hints ( Efeito Shape ) 


Remove Shape Hints 
remover Shape Hints ( Efeito Shape ) 

Bring to Front 

trazer para frente 

Move Ahead Move Behind mandar para trás 

Send to Back Lock 

trancar 

Unlock All 


destrancar tudo 
Smooth Straighten Optimize otimizar 

Lines to Fills Expand Shape Soften Edges 

Reverse r


everter frames ( quadros ) 

Frames 
Synchronize Symbols 
sincronizar símbolos 

Trace Bitmap Align 
alinhar 

Group 


agrupar 

Ungroup 


desagrupar 

Break Apart 
modificar imagem ou transformar texto em imagem para ser reeditado no Flash
Control - Controlar
PRIVATE
Play
rodar animação

Rewind
voltar a animação

Step Forward
ir à próxima cena da animação

Step Backward
voltar à última cena da animação

Test Movie
testar animação ( Crtl + Enter )

Test Scene
testar animação ; selecionar 1º frame da Cena ( Enter )

Loop Playback


EnableFrame Actions
ativar ações do frame

Enable Buttons
ativar botões

Mute Sounds
parar todos os sons

Libraries - Bibliotecas
Buttons 


botões 

Buttons-Advanced 

botões avançados 

Graphics 


gráficos 

Movie Clips 


trechos de animações 

Sounds 


sons
Window - Janela
New Window 


nova janela 

Arrange All Cascade Toolbar 
exibir os ícones das ferramentas 

Inspectors Object Frame Transform Scene Generator Controler Colors Output Generator Objects 


abrir objetos do Generator , caso tenha este programa instalado no seu computador 

Library



 abrir sua biblioteca
Help - Ajuda
Flash Help Topics 


tópicos de ajuda sobre o Flash 

Register Flash 


registrar o Flash on line 

Flash Developers Center 

visitar o site do Centro de Desenvolvedores de Flash on line 

Lessons 



lições 

Samples 



exemplos 

About Flash 



sobre o Flash

PRIVATE
EFEITO MOTION TWEENING



O efeito Motion Tweening é a animação de um objeto em duas sequências em linha reta ;
Rotação : Automatic ( Automática ) , Clockwise ( Sentido Anti-Horário ) e Counterclockwise ( Sentido Horário ) ;
Easing ( Aceleração )

Motion com Objeto

1. Desenhe uma bola 

2. Clique na ferramenta Arrow ( Seta ) ;
Clique duas vezes sobre a bola para selecionar toda a bola ( contorno e preenchimento ) 

3. Aperte a tecla F8 para transformar a bola em símbolo 

4. Abrirá uma Caixa de Diálogo : Name : bola ; behavior : graphic ;
Observe que quando se cria um símbolo , aparece um sinal ( + ) dentro do objeto 

5.  Selecione a linha do tempo = 50 

6. Insira um keyframe na linha do tempo = 50 ou seja aperte a tecla F6 ou
botão direito do mouse > Insert > Keyframe 

7. Quando se insere um keyframe, estamos repetindo o objeto do frame anterior ; mas para que haja animação devemos mudar a posição do objeto referente a linha do tempo = 50 , no caso a bola ; para outra posição 

8. Selecione a linha do tempo = 1 ;
botão direito do mouse > Create Motion Tweening , para inserir o efeito tweening motion ; observe que na linha do tempo entre a linha 1 até 49 foi exibido uma linha em cor preta, significando que nesta etapa da animação há um Tweening Motion 

9. Salve sua animação , neste caso , exer01.fla 

10. Há duas maneiras de exportar a animação ou seja para rodar a animação :
* Crtl + Enter > exer01.fla se transforma em exer01.swf ou
* File > Export Movie > exer01.fla se transforma em exer01.swf 

11. Para voltar à área de trabalho > Crtl + F4
Motion com Texto

1. Selecione a ferramenta Text ( Texto ) ;
Escolha fonte Arial Black, tamanho 28 e cor azul 

2. Digite a palavra : FLASH 

3. Clique na ferramenta Arrow ( Seta ) ;
Clique sobre o texto 

4. Aperte a tecla F8 para transformar o texto em símbolo 

5. Abrirá uma Caixa de Diálogo : Name : texto ; behavior : graphic ;
Observe que quando se cria um símbolo , aparece um sinal ( + ) dentro do texto 

6. Selecione a linha do tempo = 50 

7. Insira um keyframe na linha do tempo = 50 ou seja aperte a tecla F6 ou botão direito do mouse > Insert > Keyframe 

8. Quando se insere um keyframe, estamos repetindo o objeto do frame anterior ; mas para que haja animação devemos mudar a posição do objeto referente a linha do tempo = 50 , no caso o texto ; para outra posição 

9. Selecione a linha do tempo = 1 ;
Selecione o texto > Modify > Transform > Scale and Rotate ;
Scale : 10 e Rotate : 0 

10. Selecione a linha do tempo = 1 ;
botão direito do mouse > Create Motion Tweening , para inserir o efeito tweening motion ; observe que na linha do tempo entre a linha 1 até 49 foi exibido uma linha em cor preta, significando que nesta etapa da animação há um Tweening Motion 

11. Salve sua animação , neste caso , exer02.fla 

12. Há duas maneiras de exportar a animação ou seja para rodar a animação :
* Crtl + Enter > exer02.fla se transforma em exer02.swf ou
* File > Export Movie > exer02.fla se transforma em exer02.swf 

13. Para voltar à área de trabalho > Crtl + F4
Motion com Texto e Objeto

1. Selecione a ferramenta Oval ;
Escolha contorno em preto e preenchimento em azul claro 

2. Desenhe uma bola no lado esquerdo, na parte superior 

3. Clique na ferramenta Arrow ( Seta ) ;
Clique duas vezes sobre a bola para selecionar toda a bola ( contorno e preenchimento ) 

4. Aperte a tecla F8 para transformar a bola em símbolo 

5. Abrirá uma Caixa de Diálogo : Name : bola1 ; behavior : graphic ;
Observe que quando se cria um símbolo , aparece um sinal ( + ) dentro do objeto 

6.  Clique sobre a bola1 com o botão direito do mouse > Properties 

7. Colors Effects > Alpha > Alpha : 40 

8. Selecione a linha do tempo = 50 > F6 para inserir keyframe 

9. Crtl + K para centralizar a bola :
Vertical > Align > selecione o terceiro botão ;
Horizontal > Align > selecione o terceiro botão ;
Match Size > selecione o primeiro botão ( x ) ;
( x ) marque Align to Page 
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Modify > Transform > Scale and Rotate :
Scale : 900 ; Rotate : 0 

11. Clique duas vezes sobre o layer 1 e renomeie para bola1 

12. Clique no ícone Add Layer 
( folha branca ) criando o layer 2 

13. Clique duas vezes sobre o layer 2 e renomeie para texto1 

14. Selecione a linha do tempo = 1 

15. Selecione a ferramenta Text ( Texto ) ;
fonte : verdana ; tamanho 48 ; cor : vinho
Digite : Testando 

16. Crtl + K para centralizar o texto :
Vertical > Align > selecione o terceiro botão ;
Horizontal > Align > selecione o terceiro botão ;
Match Size > selecione o primeiro botão ( x ) ;
( x ) marque Align to Page 

17. Selecione a ferramenta Arrow ( Seta )
Clique sobre o texto 

18. Aperte a tecla F8 para transformar o texto em símbolo 

19. Abrirá uma Caixa de Diálogo : Name : texto1 ; behavior : graphic ;
Observe que quando se cria um símbolo , aparece um sinal ( + ) dentro do texto 

20.  Selecione a linha do tempo = 50 > F6 para inserir keyframe 

21. Selecione a linha do tempo = 1 

22. Selecione o texto > Modify > Transform > Flip Vertical 

23. Clique sobre a linha do tempo 1 > botão direito do mouse > Create Tweening 25. Salve o arquivo como exer03.fla 

24. Crtl + Enter e teste sua animação 

25. Crtl + F4 para voltar a área de trabalho
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Motion com Clockwise

1. Clique duas vezes no ícone 12.0 fps 

Background mude o fundo da animação para preto 

2. Desenhe uma bolinha com a cor azul 

3. Selecione a ferramenta Arrow ( Seta ) e clique sobre a borda da bolinha ;
delete a borda 

4. Clique sobre a bolinha > Crtl + D para duplicar 

5. Usando seu teclado , clique na tecla das setinhas e arraste sua bolinha para fora 
6. Pinte a segunda bolinha de verde 

7. Selecione a bolinha verde > Crtl + D para duplicar 

8. Usando seu teclado , clique na tecla das setinhas e arraste sua bolinha para fora 
9. Pinte a terceira bolinha de vermelho 

10. Selecione a bolinha vermelha > Crtl + D para duplicar 

11. Usando seu teclado , clique na tecla das setinhas e arraste sua bolinha para fora 

12. Pinte a quarta bolinha de roxo 

13. Selecione a bolinha roxa > Crtl + D para duplicar 

14. Usando seu teclado , clique na tecla das setinhas e arraste sua bolinha para fora 

15.  Pinte a quinta bolinha de laranja 

16. Selecione a bolinha laranja > Crtl + D para duplicar 

17. Usando seu teclado , clique na tecla das setinhas e arraste sua bolinha para fora 

18. Pinte a sexta bolinha de amarelo 

19. Selecione cada bolinhas separadamente e faça um círculo com elas usando a tecla das setinhas do seu teclado 

20. Selecione todas as bolinhas > F8 para transformar em símbolo 

21. Name : bolinhas ; behavior : graphic 

22. Selecione a linha do tempo = 40 > F6 para inserir keyframe 

23. Selecione a linha do tempo = 1 > Create Motion Tweening 

24. Clique o botão direito do mouse sobre a linha do tempo = 1 > Properties 

25. Tweening > Motion > Rotate : Clockwise e digite 999 times ( vezes ) ;
No item Easing ( aceleração ) :
In > a animação fica rápida e no final devegar
Out > a animação fica devegar e no final rápida
Geralmente deixar em default, isto é, no meio entre In e Out 

26. Salve o arquivo como exer04.fla 

27. Crtl + Enter e teste sua animação 

28. Crtl + F4 para voltar a área de trabalho
Efeito Fade com Texto

1. Clique duas vezes no ícone 12.0 fps 

Background mude o fundo da animação para preto 

2. Selecione a ferramenta Text ( Texto ) ;
fonte : arial black ; tamanho 48 ; cor : branco ;
digite : FLASH 

3. Selecione a ferramenta Arrow ( Seta )
Clique sobre o texto 

4. Aperte a tecla F8 para transformar o texto em símbolo 

5. Abrirá uma Caixa de Diálogo : Name : texto2 ; behavior : graphic ;
Observe que quando se cria um símbolo , aparece um sinal ( + ) dentro do texto 

6. Selecione a linha do tempo = 50 > F6 para inserir keyframe 

7. Selecione a linha do tempo = 1 > Create Motion Tweening 

8. Clique sobre o texto com o botão direito do mouse > Properties 

9. Colors Effects > Alpha > Alpha : 0 

10. Salve o arquivo como exer05.fla 

11. Crtl + Enter e teste sua animação 

12. Crtl + F4 para voltar a área de trabalho
EFEITO SHAPE

O efeito Shape transforma um objeto em outro, conhecido também como morphing ; 


Os objetos não podem ser símbolos

Tipos de Mistura ( Blend Type ):

* Distributive - os desenhos dos frames do meio da animação ficam irregulares e suaves
* Angular - os desenhos dos frames do meio da animação mantém as linhas e os cantos

Easing ( Aceleração )

Add Shape Hints

Para controlar melhor a deformação do morphing é usado o Efeito Add Shape Hints através de marcadores , mas ele só funciona se criar primeiro um shape entre dois objetos
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Shape com Polígonos
PRIVATE
1. Desenhe um quadrado

2. Clique na ferramenta Arrow ( Seta ) ;
Selecione o contorno do quadrado e delete

3. Selecione a linha do tempo = 15 > F6 para inserir um Keyframe

4. Clique na ferramenta do imã ativa para que ela esteja ativada

5. Desenhe um triângulo sobre o quadrado e pinte de outra cor

6. Selecione as partes restantes do quadrado e o contorno do triângulo e delete

7. Selecione a linha do tempo = 30 > F6 para inserir um Keyframe

8. Desative a ferramenta imã

9. Desenhe uma bola sobre o triângulo

10. Selecione as partes restantes do triângulo e o contorno da bola e delete

11. Selecione a linha do tempo = 1 até 29

12. Botão direito do Mouse > Properties > Tweening > Shape > Distributive

13. Salve sua animação , neste caso , exer08.fla

14. Crtl + Enter 

15. Para voltar à área de trabalho > Crtl + F4

Efeito de Imagem com Texto

1. File > Import e importe uma imagem com extensão png e 72 dpi de resolução 

2. Selecione a ferramenta Arrow ( Seta ) 

3. Selecione a imagem > Crtl + B ou Modify > Break Apart para transformar a imagem em bitmap 

4.  Insira um keyframe na linha do tempo = 50 

5. Deselecione a imagem 

6. Digite sobre a imagem : E F E I T O em arial back, 48 e pinte de uma cor 

7. Clique sobre a imagem e delete 

8. Selecione o texto > Crtl + B ou Modify > Break Apart para transformar o texto em bitmap 

9. Selecione a linha do tempo = 1 até 49 

10. Botão direito do Mouse > Properties > Tweening > Shape > Angular 

11. Salve sua animação , neste caso, exer09.fla 

12. Crtl + Enter 

13. Para voltar à área de trabalho > Crtl + F4
Add Shape Hints com Polígono

1. Desenhe uma quadrado 
2.  Clique na ferramenta Arrow ( Seta ) ;
Selecione o contorno do quadrado e delete 
3. Selecione a linha do tempo = 30 > F6 para inserir um Keyframe 

4. Clique na ferramenta do imã para desativar 

5. Desenhe uma bola sobre o quadrado 

6. Selecione as partes restantes do quadrado e o contorno da bola e delete 

7. Selecione a linha do tempo = 1 até 29 

8. Botão direito do Mouse > Properties > Tweening > Shape > Distributive 

9. Selecione a linha do tempo = 1 

10. Modify > Transform > Add Shape Hints ;
será exibido uma bola amarela com a letra A 

11. Arraste o A para uma extremidade do quadrado 

12. Clique sobre A > botão direito do mouse > Add Hints ( Adicionar Hints ) 

13. Será exibido uma bola amarela com a letra B 

14. Arraste o B para uma extremidade do quadrado 

15. Repita as instruções mencionadas nos itens 12 à 14 e insira os hints C , D , E 

16. Selecione a linha do tempo = 30 

17. Será exibido uma bola verde E no meio do polígono , arraste para extremidade cada hints 
18. Salve sua animação , neste caso , exer10.fla 

19. Crtl + Enter 
20. Para voltar à área de trabalho > Crtl + F4
SÍMBOLOS

PRIVATE


Os símbolos podem ser : 
· graphic ( gráfico ) 

· button ( botão ) 

· movie clip ( pequena animação ) 
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buttons ( botões )
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buttons-advanced ( botões avançados )
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graphics ( gráficos )
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movie clips ( pequenas animações )
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sounds ( sons )







Window > Library
onde fica armazenado os símbolos criados por você


[image: image105.png]& Scene1



PRIVATE

File > Import ( Arquivo > Importar )
quando se importa uma imagem, o Flash faz uma cópia automaticamente na sua biblioteca

Como personalizar sua Library ( Biblioteca )
PRIVATE
Caso você queira armazenar seus símbolos preferidos de maneira personalizada



1. Crie um arquivo novo no Flash

2. Salve com seu nome : exemplo : beto.fla em Arquivos de Programas ou Program Files > Macromedia > Flash 4 > Libraries

3. Crie seus símbolos preferidos e salve seu arquivo

4. Feche seu arquivo personalizado

5. Crie uma nova animação

6. Libraries > seu_nome ( neste caso beto )

7. Escolha o símbolo que queira inserir na nova animação

Como criar um símbolo
PRIVATE
1. Window > Library ( Janela > Biblioteca )

2. Options > New Symbol ( Opção > Novo Símbolo )

3. Name : digite o nome símbolo
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4. Behavior : escolha o tipo do símbolo

5. Desenhe um símbolo

6. Terminado a edição do símbolo;
clique em Edit Scene ( Editar Cena ) 
;
caso queira voltar na edição do símbolo > Edit Symbols ( Editar Símbolo )

7. Observe que o símbolo recém construído fica automaticamente dentro da Library ( Biblioteca )

8. Para inserir o símbolo para Cena :
selecione na Library o símbolo ;
clique no desenho do símbolo e arraste para sua Cena

Outras ferramentas para Símbolos
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New Symbol > criar novo símbolo
New Folder > criar nova pasta
Properties > propriedades do símbolo
Delete > deletar símbolo 



Subir ou descer para o próximo símbolo
Aumentar a área de visualização sobre os símbolos
Diminuir a área de visualização sobre os símbolos
Ir para o primeiro símbolo

Options ( Opções do Símbolo )

New Symbol 


criar novo símbolo 

New Folder 
criar nova pasta , ou seja , serve para organizar os símbolos por categorias 

Rename 



renomear símbolo 

Move to New Folder 

mover para nova pasta 

Duplicate 



duplicar símbolo 

Delete 



deletar símbolo 

Edit 




editar símbolo 

Properties 



propriedades do símbolo 

Select Unused items 

selecionar símbolos que não estão sendo usados Update 



atualizar símbolos 

Play 




rodar símbolo ( movie clip , botão e som ) 

Expand Folder 


expandir pasta 

Collapse Folder 


fechar pasta 

Expand All Folders 

expandir todas as pastas 

Collapse All Folders 

fechar todas as pastas 

Keep Use Counts Update Keep Use Counts Now
Propriedades de um Símbolo
Definition ( Definição )
     Behavior 
( Comportamento ) 


Graphic , Button , Movie Clip
         Play Mode Option
( maneira para rodar a animação )
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Graphic - determina quantas vezes irá rodar o símbolo gráfico : Loop ( infinitamente ) , Play Once ( rodar uma vez ) , Single Frame ( símbolo fica  Button - determina como funcionar o botão : Track as Button , Track as Menu Item 
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Movie Clip - determina a instância de um símbolo , ou seja, um símbolo movie clip pode ter várias instâncias , mas com ações diferentes : Instance Name ( Nome da Instância ) 


INCLUDEPICTURE  \d "simbolo_arquivos/simbolo4.gif"

Edit Symbol - editar símbolo 

Duplicate Symbol - duplicar símbolo 

Color Effect ( Efeito de Cor )
Um mesmo símbolo pode ter cores diferentes na área de trabalho 

None - nenhuma mudança da forma original do símbolo 

Brigthness - dar ou retirar brilho do símbolo 

Tint - pintar o símbolo de outra cor 

Alpha - clarear o símbolo 

Special - especificar a cor em RGB 

Action ( Ação )
somente o símbolo button se dá uma ação no próprio botão , para os outros símbolos as ações são inseridas na linha do tempo
Símbolo Movie Clip

1. Neste exemplo vamos criar uma árvore de natal 

2. File > Import e importe uma imagem de uma árvore em extensão png com resolução de 72 dpi 

3.  Window > Library > Options > New Symbol para criar novo símbolo 

4. Name: bolinhas ; behavior : movie clip 

5. Desenhe uma bolinha pequena de cor vermelha gradiente 

6. Selecione a borda e delete 

7. Crtl + K para alinhar a bola no centro ( em cima do sinal + )
Vertical > Align > selecione o terceiro botão ;
Horizontal > Align > selecione o terceiro botão ;
Match Size > selecione o primeiro botão ( x ) ;
( x ) marque Align to Page 

8. Selecione a linha do tempo = 2 > F6 ou Insert > Keyframe 

9. Com a ferramenta balde pinte a bolinha de verde gradiente 

10. Selecione a linha do tempo = 3 > F6 ou Insert > Keyframe 

11. Com a ferramenta balde pinte a bolinha de cinza gradiente 

12. Selecione a linha do tempo =4 > F6 ou Insert > Keyframe 
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Com a ferramenta balde pinte a bolinha de azul gradiente 

14. Volte para edição da Cena 1 > Edit Scene 
 

15. Arraste a bolinha movie clip da library para a árvore por várias vezes 

16. Selecione a linha do tempo = 40 > F5 ou Insert > Frame 

17. Salve o arquivo como exer11.fla 

18. Crtl + Enter e teste sua animação 

19. Crtl + F4 para voltar a área de trabalho
Símbolo Movie Clip
1. Neste exemplo vamos fazer a tela de um computador mudar de cor  
2. File > Import e importe uma imagem de computador em extensão png com resolução de 72 dpi 

3. [image: image113.png]( X )



Selecione a imagem > Crtl B ou Modify > Break Apart para transformar a imagem em bitmap 

4. Selecione a ferramenta varinha mágica 
5. Clique na segunda varinha mágica > Magic Wand Properties ( Propriedades da Varinha Mágica ) 

6. Threshold : 10 e Smoothing : Normal 

7. Selecione a primeira varinha mágica > Magic Wand ( Varinha Mágica ) 

8. Clique sobre a tela da imagem do computador , caso ela não selecione toda a tela, volta à segunda varinha mágica e aumente o Threshold para 20 e assim sucessivamente até que selecione toda a tela 

9. Aperte F8 e transforme a tela em símbolo movie clip 

10. Name: tela ; behavior : movie clip 

11. Window > Library ( Janela > Biblioteca ) 

12. Selecione o símbolo tela e clique duas vezes sobre o desenho da tela 

13.  Insira um keyframe na linha do tempo = 2 e pinte de uma outra cor 

14.  Insira um keyframe na linha do tempo = 3 e pinte de uma outra cor 

15. [image: image114.png]


 Insira um keyframe na linha do tempo = 4 e pinte de uma outra cor 

16. Volte para edição da Cena 1 > Edit Scene 

17. Selecione a linha do tempo = 50 > F5 ou Insert > Frame 

18. Salve o arquivo como exer12.fla 

19.  Crtl + Enter e teste sua animação 

20. Crtl + F4 para voltar a área de trabalho
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